<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">

<head>
	<meta charset="UTF-8" />
    
    <meta name="viewport" content="width=device-width, initial-scale=1"/>
    
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	
	
	<title>2017 NAACP Awards | The California Channel</title>
	<link rel="shortcut icon" href="http://www.calchannel.com/wp-content/uploads/2016/04/favicon-wp-copy2.png"/>	
	<link rel="stylesheet" href="http://www.calchannel.com/wp-content/themes/sensetheme-child/style.css">
	
	<link rel="pingback" href="http://www.calchannel.com/xmlrpc.php">
    
	
	<meta property="og:title" content="2017 NAACP Awards" />
<meta property="og:description" content="" />
<link rel="alternate" type="application/rss+xml" title="The California Channel &raquo; Feed" href="http://www.calchannel.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The California Channel &raquo; Comments Feed" href="http://www.calchannel.com/comments/feed/" />
<meta property="og:title" content="2017 NAACP Awards"/><meta property="og:type" content="article"/><meta property="og:url" content="http://www.calchannel.com/2017-naacp-awards/"/><meta property="og:site_name" content="The California Channel"/><meta property="og:image" content="http://www.calchannel.com/wp-content/uploads/2017/02/NAACP_Logo_With_Cal_Tag-403x315.png"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.calchannel.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.7"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='essb-cct-style-css'  href='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/click-to-tweet/assets/css/styles.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-css'  href='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/assets/css/metro-retina/easy-social-share-buttons.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-sidebar-css'  href='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/assets/css/essb-sidebar.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-mailform-css'  href='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/assets/css/essb-mailform.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='essb-social-fanscounter-css'  href='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/social-fans-counter/assets/css/essb-social-fanscounter.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/framework/bootstrap/css/bootstrap.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='fa-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/fonts/awesome-fonts/css/font-awesome.min.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='fa-snapchat-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/fa-snapchat.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/flexslider.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='bkstyle-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/bkstyle.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='bkresponsive-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/responsive.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='tipper-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/jquery.fs.tipper.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='justifiedgallery-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/justifiedGallery.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='justifiedlightbox-css'  href='http://www.calchannel.com/wp-content/themes/sensetheme/css/magnific-popup.css?ver=4.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='rhc-print-css-css'  href='http://www.calchannel.com/wp-content/plugins/calendarize-it/css/print.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='calendarizeit-css'  href='http://www.calchannel.com/wp-content/plugins/calendarize-it/css/frontend.min.css?ver=3.2.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='rhc-last-minue-css'  href='http://www.calchannel.com/wp-content/plugins/calendarize-it/css/last_minute_fixes.css?ver=1.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='redux-google-fonts-bk_option-css'  href='http://fonts.googleapis.com/css?family=Oswald%3A300%2C400%2C700%7CArchivo+Narrow%3A400%2C700%2C400italic%2C700italic%7CLato%3A100%2C300%2C400%2C700%2C900%2C100italic%2C300italic%2C400italic%2C700italic%2C900italic&#038;ver=1460581640' type='text/css' media='all' />
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/calendarize-it/js/bootstrap.min.js?ver=3.0.0'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/calendarize-it/js/bootstrap-select.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/droppable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/calendarize-it/js/deprecated.js?ver=bundled-jquery-ui'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var RHC = {"ajaxurl":"http:\/\/www.calchannel.com\/","mobile_width":"480","last_modified":"09ec67ac45338f66041a7ed154e1e051","tooltip_details":[],"visibility_check":"","gmt_offset":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/calendarize-it/js/frontend.min.js?ver=3.4.3.5'></script>
<link rel='https://api.w.org/' href='http://www.calchannel.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.calchannel.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.calchannel.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='WE ARE EXPERIENCING TECHNICAL DIFFICULTIES' href='http://www.calchannel.com/we-are-experiencing-technical-difficulties/' />
<meta name="generator" content="WordPress 4.4.7" />
<link rel="canonical" href="http://www.calchannel.com/2017-naacp-awards/" />
<link rel='shortlink' href='http://www.calchannel.com/?p=5662' />
<link rel="alternate" type="application/json+oembed" href="http://www.calchannel.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.calchannel.com%2F2017-naacp-awards%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.calchannel.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.calchannel.com%2F2017-naacp-awards%2F&#038;format=xml" />
<style>
.rhcalendar.not-widget.rhc_holder div.fc-view.fc-agenda > div > div:last-child {
height:auto !important;
}
</style>
<script type="text/javascript">
function fc_no_vertical_scroll_bar(view){
	var h;
	if (view.name == "month") {
	    h = NaN;
	}
	else {
	    h = 99999;
	}
	jQuery(this).fullCalendar('option', 'contentHeight', h);
}
</script>
<style type="text/css">.essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { color: #777777;content: "shares";display: block;font-size: 11px;font-weight: normal;text-align: center;text-transform: uppercase;margin-top: -5px; } .essb_links_list li.essb_totalcount_item .essb_t_l_big, .essb_links_list li.essb_totalcount_item .essb_t_r_big { text-align: center; } .essb_displayed_sidebar .essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_displayed_sidebar .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { margin-top: 0px; } .essb_displayed_sidebar_right .essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_displayed_sidebar_right .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { margin-top: 0px; } .essb_totalcount_item_before, .essb_totalcount_item_after { display: block !important; } .essb_totalcount_item_before .essb_totalcount, .essb_totalcount_item_after .essb_totalcount { border: 0px !important; } .essb_counter_insidebeforename { margin-right: 5px; font-weight: bold; } .essb_width_columns_1 li { width: 100%; } .essb_width_columns_1 li a { width: 92%; } .essb_width_columns_2 li { width: 49%; } .essb_width_columns_2 li a { width: 86%; } .essb_width_columns_3 li { width: 32%; } .essb_width_columns_3 li a { width: 80%; } .essb_width_columns_4 li { width: 24%; } .essb_width_columns_4 li a { width: 70%; } .essb_width_columns_5 li { width: 19.5%; } .essb_width_columns_5 li a { width: 60%; } .essb_links li.essb_totalcount_item_before, .essb_width_columns_1 li.essb_totalcount_item_after { width: 100%; text-align: left; } .essb_network_align_center a { text-align: center; } .essb_network_align_right .essb_network_name { float: right;} .essb_displayed_sidebar_right, .essb_displayed_sidebar { top: 35% !important;}</style>
<script type="text/javascript">var essb_settings = {"ajax_url":"http:\/\/www.calchannel.com\/wp-admin\/admin-ajax.php","essb3_nonce":"bc3b736bc1","essb3_plugin_url":"http:\/\/www.calchannel.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_facebook_total":true,"essb3_admin_ajax":false,"essb3_internal_counter":false,"essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","essb3_counter_button_min":0,"essb3_counter_total_min":0,"blog_url":"http:\/\/www.calchannel.com\/","ajax_type":"wp","essb3_postfloat_stay":false,"essb3_no_counter_mailprint":false,"essb3_single_ajax":false,"twitter_counter":"api"};</script><link media="all" type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Lato:100,300,700,900" />        <script type="text/javascript">
            var ajaxurl = 'http://www.calchannel.com/wp-admin/admin-ajax.php';
        </script>
    		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		    
    <style type='text/css' media="all">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</style>
        <style type="text/css" title="dynamic-css" class="options-output">.header-wrap{background-color:transparent;background-repeat:no-repeat;background-position:left bottom;}#top-menu>ul>li, #top-menu>ul>li .sub-menu li, .bk_u_login, .bk_u_logout, .bk-links-modal{font-family:Oswald;font-weight:400;font-style:normal;}.main-nav #main-menu .menu > li, .main-nav #main-menu .menu > li > a, .mega-title h3, .header .logo.logo-text h1, .bk-sub-posts .post-title,
                            .comment-box .comment-author-name, .today-date{font-family:Oswald;font-weight:400;font-style:normal;}.review-score, .bk-criteria-wrap > span{font-family:Oswald;font-weight:400;font-style:normal;}.meta, .post-category, .widget_comment .cm-header div, .module-feature2 .post-author, .comment-box .comment-time, .share-box ul li .share-item__value,.share-box .bk-share .share-item__valuem, .share-total, .loadmore span.ajaxtext, .woocommerce-page a.button, #comment-submit, 
                            .woocommerce-page #review_form #respond .form-submit #submit, .woocommerce-page div.product form.cart .button, .woocommerce-page input.button, 
                            .woocommerce-page .cart-collaterals .shipping_calculator .button, .woocommerce-page .cart-collaterals .shipping_calculator h2, 
                            .woocommerce span.onsale, .woocommerce-page span.onsale, .breadcrumbs, .s-post-nav .nav-title span, .product_meta .post-tags-title,
                            .woocommerce-page .widget_price_filter .price_slider_amount .button, .button, .woocommerce-page div.product form.cart table td select, .woocommerce-page div.product form.cart table td .reset_variations, 
                            .bk-search-content .nothing-respond, .bk_small_cart .woocommerce.widget_shopping_cart .buttons a, .woocommerce-page div.product p.price ins, .woocommerce-cart .cart-collaterals .cart_totals .woocommerce-shipping-calculator .button {font-family:"Archivo Narrow";font-weight:400;font-style:normal;}h1, h2, h3, h4, h5, #mobile-top-menu > ul > li, #mobile-menu > ul > li, #footer-menu a, .bk-copyright, 
                            .widget-social-counter .counter, .widget-social-counter ul li .data .subscribe, .woocommerce-page div.product .woocommerce-tabs ul.tabs li a,
                            #bbpress-forums ul.forum-titles, .breadcrumbs .location, #bbpress-forums li.bbp-header, .woocommerce-page ul.product_list_widget li a, 
                            .bk_small_cart .woocommerce.widget_shopping_cart .total, .bk_small_cart .widget_shopping_cart .cart_list a,
                            .bk_tabs  .ui-tabs-nav li, .bkteamsc .team-member .member-name, .buttonsc {font-family:Oswald;font-weight:400;font-style:normal;}body, textarea, input, p, 
                            .entry-excerpt, .comment-text, .comment-author, .article-content,
                            .comments-area, .tag-list, .bk-mega-menu .bk-sub-posts .feature-post .menu-post-item .post-date, .comments-area small{font-family:Lato;font-weight:400;font-style:normal;}</style><style id="righthere_css" type="text/css">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</style>    
    <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-30732357-1', 'auto');
  ga('send', 'pageview');

</script></head>

<body class="single single-post postid-5662 single-format-video">
	
	<div id="page-wrap" >
        <div id="main-mobile-menu">
            <div class="block">
                <div id="mobile-inner-header">
                    <a class="mobile-menu-close" href="#" title="Close"><i class="fa fa-arrow-left"></i></a>
                </div>
                                                    <div class="main-menu">
                        <h3 class="menu-location-title">
                            Main Menu                        </h3>
                        <div id="mobile-menu" class="menu-nav-container"><ul id="menu-nav" class="menu"><li id="menu-item-3830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3830"><a href="http://www.calchannel.com">Home</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-769"><a href="http://www.calchannel.com/live-webcast/">LIVE Webcast</a></li>
<li id="menu-item-773" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-773"><a href="http://www.calchannel.com/video-on-demand/">Video on Demand</a></li>
<li id="menu-item-771" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-771"><a href="http://www.calchannel.com/tv-schedule/">TV Schedule</a></li>
<li id="menu-item-3806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3806"><a href="http://www.calchannel.com/local-listing/">Local Listing</a></li>
<li id="menu-item-3807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3807"><a href="http://www.calchannel.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-774" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-774"><a href="http://www.calchannel.com/contact/">Contact</a></li>
	<li id="menu-item-3808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3808"><a href="http://www.calchannel.com/history/">History</a></li>
	<li id="menu-item-3810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3810"><a href="http://www.calchannel.com/the-california-channel-board-of-directors/">Board of Directors</a></li>
</ul>
</li>
</ul></div>                    </div>
                            </div>
        </div>
        <div id="page-inner-wrap">
            <div class="page-cover mobile-menu-close"></div>
            <div class="bk-page-header">            
                <div class="header-wrap">
                    <div class="top-bar bk-menu-light">
                        <div class="bkwrapper container">
                            <div class="top-nav clearfix">
                                                                                                                                  
                            </div><!--top-nav-->
                        </div>
                    </div><!--top-bar-->
                                        <div class="header container">
                        <div class="row">
                            <div class="col-md-12">
                    			<div class="header-inner ">
                        			<!-- logo open -->
                                                                    			<div class="logo">
                                            <a href="http://www.calchannel.com">
                                                <img src="http://www.calchannel.com/wp-content/uploads/2015/12/web-header-01.png" alt="logo"/>
                                            </a>
                            			</div>
                            			<!-- logo close -->
                                                                                                                </div>
                            </div>
                        </div>
                    </div>   
                            		</div>
                <!-- nav open -->
        		<nav class="main-nav bk-menu-light">
                    <div class="main-nav-inner bkwrapper container">
                        <div class="main-nav-container clearfix ">
                                <div class="main-nav-wrap">
                                                                     <div class="mobile-menu-wrap">
                                        <h3 class="menu-title">
                                            The California Channel                                        </h3>
                                        <a class="mobile-nav-btn" id="nav-open-btn"><i class="fa fa-bars"></i></a>  
                                    </div>
                                    
                                    <div id="main-menu" class="menu-nav-container"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3830"><a href="http://www.calchannel.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-769"><a href="http://www.calchannel.com/live-webcast/">LIVE Webcast</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-773"><a href="http://www.calchannel.com/video-on-demand/">Video on Demand</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-771"><a href="http://www.calchannel.com/tv-schedule/">TV Schedule</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3806"><a href="http://www.calchannel.com/local-listing/">Local Listing</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3807"><a href="http://www.calchannel.com/about/">About</a><div class="bk-dropdown-menu"><div class="bk-sub-menu-wrap"><ul class="bk-sub-menu clearfix">	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-774"><a href="http://www.calchannel.com/contact/">Contact</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3808"><a href="http://www.calchannel.com/history/">History</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3810"><a href="http://www.calchannel.com/the-california-channel-board-of-directors/">Board of Directors</a></li>
</ul></div></div></li>
</ul></div>                                </div>
                                <div class="ajax-search-wrap"><div id="ajax-form-search" class="ajax-search-icon"><i class="fa fa-search"></i></div><form class="ajax-form" method="get" action="http://www.calchannel.com"><fieldset><input id="search-form-text" type="text" class="field" name="s" autocomplete="off" value="" placeholder="Search this Site.."></fieldset></form> <div id="ajax-search-result"></div></div> 
                        </div>    
                    </div><!-- main-nav-inner -->       
        		</nav>
                <!-- nav close -->
            </div>                
          
            <div class="bk-breadcrumbs-wrap bkwrapper container"><div class="breadcrumbs"><i class="fa fa-home"></i><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.calchannel.com/"><span itemprop="title">Home</span></a></span><span class="delim">&rsaquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="http://www.calchannel.com/category/feature/"><span itemprop="title">Feature</span></a></span><span class="delim">&rsaquo;</span><span class="current">2017 NAACP Awards</span></div></div>            
            <!-- backtop open -->
    		                <div id="back-top"><i class="fa fa-long-arrow-up"></i></div>
                		<!-- backtop close -->                        <div class="single-page " itemscope itemtype="http://schema.org/Article">
                        <div class="article-wrap bkwrapper container">
                <div class="row bk-in-single-page bksection">
                    <div class="main col-md-8">
                                            <header id="bk-normal-feat" class="clearfix"></header><div class="s_header_wraper"><div class="s-post-header container"><h1 itemprop="headline">2017 NAACP Awards</h1><div class="meta"><div class="post-category"><a href="http://www.calchannel.com/category/feature/">Feature</a></div><div class="post-date" itemprop="datePublished">February 23, 2017</div><div class="post-author" itemprop="author">by <a href="http://www.calchannel.com/author/calchannel/">calchannel</a></div></div></div></div><!-- end single header -->                                            <div class="article-content clearfix" itemprop="articleBody">
<!-- ARTICAL CONTENT -->
                                                        <p><iframe width="1200" height="900" src="https://www.youtube.com/embed/1c0Vo2xUJuE?feature=oembed" frameborder="0" allowfullscreen></iframe></p>
<div class="essb_break_scroll"></div>                                                    </div><!-- end article content --> 
                    <!-- TAGS -->
                    <!-- NAV -->
                    <!-- SHARE BOX -->
                    <!-- AUTHOR BOX -->
                     
                    <meta itemprop="author" content="calchannel"><meta itemprop="headline " content="2017 NAACP Awards"><meta itemprop="datePublished" content="2017-02-23T23:19:15+00:00"><meta itemprop="image" content="http://www.calchannel.com/wp-content/uploads/2017/02/NAACP_Logo_With_Cal_Tag.png"><meta itemprop="interactionCount" content="UserComments:0"/><!-- RELATED POST -->
                      
                        <div class="related-box">
                            <h3>Related articles</h3>
                            <div class="bk-related-posts"><ul class="related-posts row clearfix"><li class="item row-type content_out col-md-4 col-sm-4"><div class="thumb hide-thumb"><a href="http://www.calchannel.com/election-2016-what-worked-what-we-can-do-better/"><img width="350" height="320" src="http://www.calchannel.com/wp-content/uploads/2016/06/iStock_000006407774Medium1-e1427127515691-350x320.jpg" class="attachment-bk350_320 size-bk350_320 wp-post-image" alt="Close up of the flag of the US State of California, square image" /></a></div><div class="post-c-wrap"><h4><a href=http://www.calchannel.com/election-2016-what-worked-what-we-can-do-better/>Election 2016: What Worked &#038; What We Can Do Better</a></h4><div class="meta"><div class="meta"><div class="post-category"><a href="http://www.calchannel.com/category/feature/">Feature</a></div><div class="post-date" itemprop="datePublished">June 21, 2016</div></div></div></div></li><li class="item row-type content_out col-md-4 col-sm-4"><div class="thumb hide-thumb"><a href="http://www.calchannel.com/senate-democrats-reactions-to-gov-browns-2017-state-of-state-address/"><img width="350" height="320" src="http://www.calchannel.com/wp-content/uploads/2017/01/1168437_1280x720-350x320.jpg" class="attachment-bk350_320 size-bk350_320 wp-post-image" alt="1168437_1280x720" /></a></div><div class="post-c-wrap"><h4><a href=http://www.calchannel.com/senate-democrats-reactions-to-gov-browns-2017-state-of-state-address/>Senate Democrats Reactions to Gov. Brown's 2017 State of State Address</a></h4><div class="meta"><div class="meta"><div class="post-category"><a href="http://www.calchannel.com/category/feature/">Feature</a>, <a href="http://www.calchannel.com/category/uncategorized/">Uncategorized</a></div><div class="post-date" itemprop="datePublished">January 25, 2017</div></div></div></div></li><li class="item row-type content_out col-md-4 col-sm-4"><div class="thumb hide-thumb"><a href="http://www.calchannel.com/california-constitutionals-with-betty-yee/"><img width="350" height="320" src="http://www.calchannel.com/wp-content/uploads/2016/12/california-constitution-1920-1080-350x320.png" class="attachment-bk350_320 size-bk350_320 wp-post-image" alt="california-constitution-1920-1080" /></a></div><div class="post-c-wrap"><h4><a href=http://www.calchannel.com/california-constitutionals-with-betty-yee/>California Constitutionals with Betty Yee</a></h4><div class="meta"><div class="meta"><div class="post-category"><a href="http://www.calchannel.com/category/feature/">Feature</a></div><div class="post-date" itemprop="datePublished">December 12, 2016</div></div></div></div></li></ul></div>                        </div>
                    <!-- COMMENT BOX -->
                                        </div>
                                        <!-- Sidebar -->
                                        <div class="sidebar col-md-4">
                        <aside class="sidebar-wrap " id="bk-single-sidebar">
                            <aside id="widget-ads-2" class="widget widget-ads">			<a class="ads-link" target="_blank" href="http://olive.calchannel.com">
				<img class="ads" src="http://www.calchannel.com/wp-content/uploads/2015/12/OLIVE-AD.jpg" alt="">
			</a>
		</aside><aside id="rss-3" class="widget widget_rss"><div class="bk-header"><div class="widget-title"><h3><a class="rsswidget" href="http://capitolweekly.net/news/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://www.calchannel.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://capitolweekly.net/">Capitol Weekly</a></h3></div></div><ul><li><a class='rsswidget' href='http://capitolweekly.net/ask-emily-taxes/'>Ask Emily: Health and taxes</a> <span class="rss-date">February 24, 2017</span></li><li><a class='rsswidget' href='http://capitolweekly.net/state-senator-nguyen-ordered-floor/'>State senator ordered off floor</a> <span class="rss-date">February 23, 2017</span></li><li><a class='rsswidget' href='http://capitolweekly.net/california-bar-exam-passage-rate-failure/'>Bar exam failure rates draw scrutiny</a> <span class="rss-date">February 23, 2017</span></li><li><a class='rsswidget' href='http://capitolweekly.net/capitol-weekly-podcast-chris-austin/'>Capitol Weekly Podcast: Chris Austin</a> <span class="rss-date">February 23, 2017</span></li><li><a class='rsswidget' href='http://capitolweekly.net/california-tale-one-room-schoolhouse/'>A California tale: The one-room schoolhouse</a> <span class="rss-date">February 22, 2017</span></li></ul></aside>		<aside id="recent-posts-3" class="widget widget_recent_entries">		<div class="bk-header"><div class="widget-title"><h3>Recent Posts</h3></div></div>		<ul>
					<li>
				<a href="http://www.calchannel.com/2017-naacp-awards/">2017 NAACP Awards</a>
							<span class="post-date">February 23, 2017</span>
						</li>
					<li>
				<a href="http://www.calchannel.com/we-are-experiencing-technical-difficulties/">WE ARE EXPERIENCING TECHNICAL DIFFICULTIES</a>
							<span class="post-date">February 22, 2017</span>
						</li>
					<li>
				<a href="http://www.calchannel.com/whats-possible-early-voter-engagement-with-secretary-of-state-alex-padilla/">Whats Possible? Early Voter Engagement with Secretary of State Alex Padilla</a>
							<span class="post-date">February 21, 2017</span>
						</li>
					<li>
				<a href="http://www.calchannel.com/state-of-washington-v-trump/">State of Washington v. Trump</a>
							<span class="post-date">February 7, 2017</span>
						</li>
					<li>
				<a href="http://www.calchannel.com/senate-democrats-reactions-to-gov-browns-2017-state-of-state-address/">Senate Democrats Reactions to Gov. Brown's 2017 State of State Address</a>
							<span class="post-date">January 25, 2017</span>
						</li>
				</ul>
		</aside>		                        </aside>
                    </div>
                                    </div>
            </div>
        </div>
    
	    		            
            <div class="footer">
                   
                                <div class="footer-lower">
                    <div class="container">
                        <div class="footer-inner clearfix">
                              
                            <div class="bk-copyright">© Copyright <a href="//your-site-url">The California Channel</a>. All rights reserved.</div>
                        </div>
                    </div>
                </div>
                                
    		</div>
        </div> <!-- Close Page inner Wrap -->

	</div> <!-- Close Page Wrap -->
    <script type='text/javascript'>                                    </script>    <div class="essb_links essb_counters essb_counter_modern_bottom essb_displayed_sidebar essb_share essb_template_metro-retina essb_442542740 essb_links_center print-no" id="essb_displayed_sidebar_442542740" data-essb-postid="5662" data-essb-position="sidebar" data-essb-button-style="button" data-essb-template="metro-retina" data-essb-counter-pos="bottom" data-essb-url="http://www.calchannel.com/2017-naacp-awards/" data-essb-twitter-url="http://www.calchannel.com/2017-naacp-awards/" data-essb-instance="442542740"><ul class="essb_links_list"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="bottom"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_t_nb"></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="http://www.facebook.com/sharer/sharer.php?u=http://www.calchannel.com/?p=5662&t=2017+NAACP+Awards" title="" onclick="essb_window(&#39;http://www.facebook.com/sharer/sharer.php?u=http://www.calchannel.com/?p=5662&t=2017+NAACP+Awards&#39;,&#39;facebook&#39;,&#39;442542740&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name"></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb_window(&#39;https://twitter.com/intent/tweet?text=2017+NAACP+Awards&amp;url=http://www.calchannel.com/?p=5662&amp;counturl=http://www.calchannel.com/2017-naacp-awards/&amp;hashtags=&#39;,&#39;twitter&#39;,&#39;442542740&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name"></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=http://www.calchannel.com/?p=5662" title="" onclick="essb_window(&#39;https://plus.google.com/share?url=http://www.calchannel.com/?p=5662&#39;,&#39;google&#39;,&#39;442542740&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name"></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_mailform_442542740(&#39;442542740&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name"></span></a></li></ul></div><link rel='stylesheet' id='bxSlidercss-css'  href='http://www.calchannel.com/wp-content/plugins/slider-image/style/jquery.bxslider.css?ver=4.4.7' type='text/css' media='all' />
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/comment-reply.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/assets/js/essb-mailform.js?ver=3.2.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/easy-social-share-buttons3/assets/js/easy-social-share-buttons.js?ver=3.2.4'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/cookie.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/imagesloaded.pkgd.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/jquery.flexslider.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/froogaloop2.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/modernizr.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/onviewport.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/justifiedGallery.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/jquery.magnific-popup.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/masonry.pkgd.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/module-load-post.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/jquery.fitvids.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/jquery.fs.tipper.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/SmoothScroll.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/menu.js?ver=4.4.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var justified_ids = [];
var fixed_nav = "2";
var customconfig = null;
/* ]]> */
</script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/themes/sensetheme/js/customjs.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-includes/js/wp-embed.min.js?ver=4.4.7'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/slider-image/js/jquery.bxslider.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.calchannel.com/wp-content/plugins/slider-image/js/bxslider.setup.js?ver=1.0.0'></script>
<style type="text/css"></style><script type="text/javascript">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</script></body>

</html>
